SUMMARY
On April 17, 2025 from 9:15 AM UTC to 9:22 AM UTC, customers of Zendesk Support reported apps not loading and 404 error responses from the Zendesk Application Framework Software Development Kit (ZAF SDK).
Timeline
April 17, 2025 10:01 AM UTC | April 17, 2025 03:01 AM PT
We received reports from some of our customers that they are receiving 400 errors when trying to use our ZAF SDK. Our engineering team has identified the issue and is working on a resolution.
April 17, 2025 10:07 AM UTC | April 17, 2025 03:07 AM PT
We are pleased to announce that our engineering team has successfully identified and resolved the root cause of the issue that led to some customers experiencing 404 errors while using our ZAF SDK.
April 17, 2025 10:27 AM UTC | April 17, 2025 03:27 AM PT
Thank you for your patience as our engineering team monitored system behavior following their recent fix. We are pleased to inform you that this issue is now resolved. Should you continue to experience any issues with the ZAF SDK or applications reliant on it, please do not hesitate to reach out to us.
Root Cause Analysis
This incident was caused by a web engine configuration that handles our application framework assets not being properly migrated to the visitor management and delivery tool, which resulted in the 404 error responses to our customers.
Resolution
To fix this issue, our engineers cancelled the scheduled deployment and rolled back the migration. These actions reverted all metrics back to normal and the migration was effectively undone.
Remediation Items
- Migrate application framework assets to a new distributed proxy .
- Transfer the asset framework into a dedicated segment in the next scheduled deployment.
- Add the new asset framework configuration to the reverse proxy.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.
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