Summary
On March 13, 2025 from 17:39 UTC to 18:09 UTC, Zendesk’s customers may have experienced errors preventing them from reaching our Support team via Messaging. An internal server error may have been displayed in the browser when customers were trying to initiate a chat messaging session with our Support team.
Timeline
March 13, 2025 06:19 PM UTC | March 13, 2025 11:19 AM PT
Between 17:39 and 18:09 UTC on March 13, 2025, some customers may have experienced difficulties reaching out to Zendesk Support via Messaging at support.zendesk.com. The issue has been addressed and conversations with Zendesk Support are functioning as expected at this time.
Root Cause Analysis
This incident was caused by a bug in recently-released code that caused a very specific edge case to be triggered and some messaging sessions to fail in our internal Zendesk Support instance at support.zendesk.com. This edge case was not caught in our testing due to a slight difference between our test and production environments.
Resolution
To fix this issue, our engineers identified the change that caused the issue and rolled back to a previous working version.
Remediation Items
- Implement slow rollout warnings in internal deploy systems.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.
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