Summary
On May 9, 2025, from 16:20 UTC to 18:32 UTC, customers using the Twitter (X) channel integration experienced failures in incoming tickets and agent replies due to a service outage. This resulted in permanent errors when sending or receiving messages through the Twitter Direct Messaging channel, impacting message flow and customer interactions.
Timeline
May 09, 2025 05:41 PM UTC | May 09, 2025 10:41 AM PT
We are aware of a X API v2 outage (see https://docs.x.com/status) that may impact channel integrations with Zendesk services. This can cause incoming tickets and agent replies to/from X Channel Integrations to fail due to the following error: <X::ServiceUnavailable: Service Unavailable: Service Unavailable> Please follow the X.com status updates for more details.
May 09, 2025 07:29 PM UTC | May 09, 2025 12:29 PM PT
The X API v2 issue is resolved as reported on https://docs.x.com/status. At this time all functionality has been restored.
Root Cause Analysis
This incident was caused by an outage on the Twitter (X) platform, which affected the availability of their APIs. The disruption led to failed message processing in the Twitter channel integration. There were no secondary causes identified.
Resolution
The issue was resolved once the Twitter (X) APIs returned to normal operation. Our systems resumed normal message processing following the restoration of the external service.
Remediation Items
This issue was caused by a third-party service outage, and therefore, there are no remediation actions required on Zendesk’s part.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.
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